How to: Resolve 503 Browser Error

How the Issue Manifests

  • 503 error when accessing the domain in the browser:

    503 error
  • httpd-UDS error in the domain-level error log. This log is located at /home/{unixuser}/var/{domain.com}/logs/error.log or error-ssl.log, replacing {unixuser} and {domain.com} with the corresponding information

    [root@ga-jan27 public_html]# tail -f /home/examplec/var/example.com/logs/error.log
    [Fri Feb 10 14:13:21 2023] [proxy:error] [pid 13801:tid 139821150353152] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/run/examplec-remi-safe-php74.sock (examplec-remi-safe-php74-proxy:8000) failed
    [Fri Feb 10 14:13:21 2023] [proxy_fcgi:error] [pid 13801:tid 139821150353152] [client 108.17.85.15:56513] AH01079: failed to make connection to backend: httpd-UDS
    

Cause of the Issue

The most common causes of this issue on an InterWorx server are:

  • PHP-FPM needs to be restarted

  • The PHP-FPM pool file for the domain is missing or corrupted, and needs to be recreated

How to Resolve

There are three ways that are often able to resolve the issue:

  • Restarting PHP-FPM

  • Toggling the PHP version in SiteWorx

  • Re-writing and resetting PHP-FPM files on the server

To Restart PHP-FPM

From NodeWorx

  1. Log into NodeWorx from the browser (https://ip.ad.dr.ess:2443/nodeworx)

  2. Navigate to System Services > Webserver > Overview

  3. Under Restart PHP-FPM, click Restart. This may take a few seconds to complete

    php-fpm restart button

From the CLI

  1. Log in to the server at the CLI as root, either via SSH or from the terminal

  2. Run either of the following commands–either will restart the service, though the first is recommended. This process may hang for a few seconds before completing:

    ~iworx/bin/php-fpm.pex --restart-fpm
    
    systemctl restart php-fpm
    

To Toggle the Domain PHP Version in SiteWorx

Note

This option requires that Multiple PHP is enabled on the server, and that the SiteWorx account has access to more than on PHP version.

  • Follow this documentation on how to change the PHP version for a domain in SiteWorx

    • Change the PHP version to a different version, save that change, and then change it back to the original PHP version

To Re-Write and Re-Set PHP-FPM files

  1. Log in to the server at the CLI as root, either via SSH or from the terminal

  2. Run each of the following commands, in turn. These processes may hang for a few seconds before completing:

    ~iworx/bin/php-fpm.pex --write-files
    ~iworx/bin/php-fpm.pex --reset-files
    ~iworx/bin/php-fpm.pex --restart-fpm
    
    • The flags perform the following tasks:

      • –write-files: Writes out php-fpm pools, fcgi, etc

      • –reset-files: Deletes all InterWorx-owned files and re-creates them

      • –restart-fpm: Restarts php-fpm services

Things to Keep in Mind

While this documentation describes the most common reason for a 503 error on an InterWorx server, it is possible that the error may be caused by something else. If the above steps do not resolve the issue, please submit a ticket to https://support.interworx.com.